1# Copyright (C) 2016 Intel Corporation
2#
3# SPDX-License-Identifier: MIT
4
5# systemd-boot.bbclass - The "systemd-boot" is essentially the gummiboot merged into systemd.
6#                        The original standalone gummiboot project is dead without any more
7#                        maintenance.
8#
9# Set EFI_PROVIDER = "systemd-boot" to use systemd-boot on your live images instead of grub-efi
10# (images built by image-live.bbclass)
11
12do_bootimg[depends] += "${MLPREFIX}systemd-boot:do_deploy"
13
14require conf/image-uefi.conf
15# Need UUID utility code.
16inherit fs-uuid
17
18efi_populate() {
19        efi_populate_common "$1" systemd
20
21        # systemd-boot requires these paths for configuration files
22        # they are not customizable so no point in new vars
23        install -d ${DEST}/loader
24        install -d ${DEST}/loader/entries
25        install -m 0644 ${SYSTEMD_BOOT_CFG} ${DEST}/loader/loader.conf
26        for i in ${SYSTEMD_BOOT_ENTRIES}; do
27            install -m 0644 ${i} ${DEST}/loader/entries
28        done
29}
30
31efi_iso_populate:append() {
32        cp -r $iso_dir/loader ${EFIIMGDIR}
33}
34
35inherit systemd-boot-cfg
36