1#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7# This class removes libtool .la files after do_install
8
9REMOVE_LIBTOOL_LA ?= "1"
10
11remove_libtool_la() {
12	if [ "${REMOVE_LIBTOOL_LA}" != "0" ]; then
13		find "${D}" -ignore_readdir_race -name "*.la" -delete
14	fi
15}
16
17do_install[postfuncs] += "remove_libtool_la"
18