1python __anonymous() {
2    if "linux-raspberrypi-dev" not in d.getVar("PREFERRED_PROVIDER_virtual/kernel"):
3        msg = "Skipping linux-raspberrypi-dev as it is not the preferred " + \
4              "provider of virtual/kernel."
5        raise bb.parse.SkipRecipe(msg)
6}
7
8LINUX_VERSION ?= "5.10.y"
9LINUX_RPI_BRANCH ?= "rpi-5.10.y"
10LINUX_RPI_KMETA_BRANCH ?= "yocto-5.10"
11
12# Set default SRCREVs. Both the machine and meta SRCREVs are statically set
13# to the as in 5.10 recipe, and hence prevent network access during parsing. If
14# linux-yocto-dev is the preferred provider, they will be overridden to
15# AUTOREV in following anonymous python routine and resolved when the
16# variables are finalized.
17SRCREV_machine ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-raspberrypi-dev", "${AUTOREV}", "89399e6e7e33d6260a954603ca03857df594ffd3", d)}'
18SRCREV_meta ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-raspberrypi-dev", "${AUTOREV}", "a19886b00ea7d874fdd60d8e3435894bb16e6434", d)}'
19
20KMETA = "kernel-meta"
21
22SRC_URI = " \
23    git://github.com/raspberrypi/linux.git;name=machine;branch=${LINUX_RPI_BRANCH};protocol=https \
24    git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${LINUX_RPI_KMETA_BRANCH};destsuffix=${KMETA} \
25    file://powersave.cfg \
26    file://android-drivers.cfg \
27    "
28
29require linux-raspberrypi.inc
30
31KERNEL_DTC_FLAGS += "-@ -H epapr"
32
33# Disable version check so that we don't have to edit this recipe every time
34# upstream bumps the version
35KERNEL_VERSION_SANITY_SKIP = "1"
36