1SUMMARY = "fifo maps for c++"
2HOMEPAGE = "https://github.com/nlohmann/fifo_map"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=b67209a1e36b682a8226de19d265b1e0"
6
7SRC_URI = "git://github.com/nlohmann/fifo_map.git;branch=master;protocol=https"
8
9PV = "1.0.0+git"
10
11SRCREV = "d732aaf9a315415ae8fd7eb11e3a4c1f80e42a48"
12
13UPSTREAM_CHECK_COMMITS = "1"
14
15S = "${WORKDIR}/git"
16
17# nlohmann-fifo is a header only C++ library, so the main package will be empty.
18
19RDEPENDS:${PN}-dev = ""
20
21BBCLASSEXTEND = "native nativesdk"
22
23# See https://github.com/SOCI/soci/issues/984
24CXXFLAGS:append:toolchain-clang:runtime-llvm = " -DCATCH_CONFIG_CPP11_NO_SHUFFLE"
25
26do_install() {
27    install -d ${D}${includedir}
28    install -m 0644 ${S}/src/fifo_map.hpp ${D}${includedir}
29}
30