Lines Matching +full:grub2 +full:- +full:arm64
1 require grub2.inc
3 require conf/image-uefi.conf
7 DEPENDS:append = " grub-native"
8 RDEPENDS:${PN} = "grub-common virtual-grub-bootconf"
14 S = "${WORKDIR}/grub-${PV}"
20 prefix = "" if d.getVar('EFI_PROVIDER') == "grub-efi" else "grub-efi-"
26 grubtarget = 'arm64'
34 raise bb.parse.SkipRecipe("grub-efi is incompatible with target %s" % target)
38 prefix = "grub-efi-" if prefix == "" else ""
45 EXTRA_OECONF += "--enable-efiemu=no"
52 # If 'all' is included in GRUB_BUILDIN we will include all available grub2 modules
55 # Get the list of all .mod files in grub-core build directory
56 GRUB_MKIMAGE_MODULES=$(find ${B}/grub-core/ -type f -name "*.mod" -exec basename {} .mod \;)
61 grub-mkimage -v -c ${UNPACKDIR}/cfg -p ${EFIDIR} -d ./grub-core/ \
62 -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} \
69 oe_runmake 'DESTDIR=${D}' -C grub-core install
72 find "${D}" -name modinfo.sh -type f -exec \
73 sed -i \
74 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
75 -e 's|${DEBUG_PREFIX_MAP}||g' \
76 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
79 install -d ${D}${EFI_FILES_PATH}
80 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${D}${EFI_FILES_PATH}/${GRUB_IMAGE}
91 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${DEPLOYDIR}
96 FILES:${PN} = "${libdir}/grub/${GRUB_TARGET}-efi \
101 # 64-bit binaries are expected for the bootloader with an x32 userland
102 INSANE_SKIP:${PN}:append:linux-gnux32 = " arch"
103 INSANE_SKIP:${PN}-dbg:append:linux-gnux32 = " arch"
104 INSANE_SKIP:${PN}:append:linux-muslx32 = " arch"
105 INSANE_SKIP:${PN}-dbg:append:linux-muslx32 = " arch"