Lines Matching full:dts
50 ${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts \
51 ${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts/* \
57 DT_FILES_PATH[doc] = "Path to the directory containing dts files to build. Defaults to source direc…
59 …T_FILES[doc] = "Space-separated list of dts or dtb files (relative to DT_FILES_PATH) to build. If …
92 # determine if a dts file is an overlay by checking if it uses "/plugin/;"
101 dts = os.path.basename(dtspath)
102 dtname = os.path.splitext(dts)[0]
103 bb.note("Processing {0} [{1}]".format(dtname, dts))
110 ppargs += ["-o", "{0}.pp".format(dts), dtspath]
115 isoverlay = devicetree_source_is_overlay("{0}.pp".format(dts))
126 dtcargs += ["-I", "dts", "-O", "dtb", "{0}.pp".format(dts)]
134 dtfiles = [ re.sub(r"\.dtbo?$", ".dts", dtfile) for dtfile in dtfiles ]
136 for dts in dtfiles or os.listdir(listpath):
137 dtspath = os.path.join(listpath, dts)
139 …if not(os.path.isfile(dtspath)) or not(dts.endswith(".dts") or devicetree_source_is_overlay(dtspat…
140 continue # skip non-.dts files and non-overlay files