Lines Matching refs:t

36 # are used since exec_func doesn't handle return values.
305 return subprocess.check_output(["stat", "-f", "-c", "%t", path]).decode('utf-8').strip()
307 bb.warn("Can't get filesystem id of: %s" % path)
310 # Check that the path isn't located on nfs.
314 return "The %s: %s can't be located on nfs.\n" % (name, path)
322 return "The %s (%s) can't be on a case-insensitive file system.\n" % (name, path)
325 # Check that path isn't a broken symlink
403 …# Check that we don't have duplicate entries in PACKAGE_ARCHS & that TUNE_PKGARCH is in PACKAGE_AR…
427 # Patch before 2.7 can't handle all the features in git-style diffs. Some
428 # patches may incorrectly apply, and others won't apply at all.
473 …return "OpenEmbedded doesn't work under WSLv1, please upgrade to WSLv2 if you want to run builds o…
514 return "Your tar doesn't support --xattrs, please use GNU tar.\n"
595 …he layout of TMPDIR changed for Recipe Specific Sysroots.\nConversion doesn't make sense and this …
612 # Check that SSTATE_DIR isn't on a filesystem with limited filename length (eg. eCryptFS)
616 # If we don't have permissions to SSTATE_DIR, suggest the user set it as an SSTATE_MIRRORS
667 # Check user doesn't have ASSUME_PROVIDED = instead of += in local.conf
671 # Check that TMPDIR isn't on a filesystem with limited filename length (eg. eCryptFS)
677 status.addresult("TMPDIR is setgid, please don't build in a setgid directory")
679 status.addresult("TMPDIR is setuid, please don't build in a setuid directory")
681 # Check that a user isn't building in a path in PSEUDO_IGNORE_PATHS
726 "an empty entry, a './' or a '.'.\n\t This is unsafe and means your "\
727 "layer configuration is adding empty elements to BBPATH.\n\t "\
737 # The length of TMPDIR can't be longer than 410
740 # Check that TMPDIR isn't located on nfs
790 …status.addresult("Please don't use inherit directive in your local.conf. The directive is supposed…
799 # Check that these variables don't use tilde-expansion as we don't do that
804 …_DIR is set, exists and is writable. In theory, we should never even hit the check if DL_DIR isn't
848 raise_sanity_error("/tmp shouldn't be mounted with noexec.", d)
868 … %s directory path. Please move the installation to a directory which doesn't include any + charac…
870 … %s directory path. Please move the installation to a directory which doesn't include any @ charac…
872 …Please move the installation to a directory which doesn't include a space since autotools doesn't
874 … string formatting. Please move the installation to a directory which doesn't include any % charac…
920 # Check sstate mirrors aren't being used with a local hash server and no remote
925 # Check that TMPDIR hasn't changed location since the last time we were run