Lines Matching +full:build +full:- +full:system +full:- +full:centos
4 # SPDX-License-Identifier: MIT
43 SANITY_DIFF_TOOL ?= "diff -u"
115 if start != -1 and (len(bbpath_line) != (start + 1)):
147 # Handle rename of meta-yocto -> meta-poky
148 # This marks the start of separate version numbers but code is needed in OE-Core
152 if 'meta-yocto' in layers:
155 index, meta_yocto_line = sanity_conf_find_line(r'.*meta-yocto[\'"\s\n]', lines)
157 lines[index] = meta_yocto_line.replace('meta-yocto', 'meta-poky')
188 bb.fatal(""" OE-core's config sanity checker detected a potential misconfiguration.
202 overrides = localdata.getVar("OVERRIDES", False) + ":virtclass-multilib-" + multilib
204 bb.debug(2, "Sanity-checking tuning '%s' (%s) features:" % (tune, multilib))
205 features = (localdata.getVar("TUNE_FEATURES:tune-%s" % tune) or "").split()
248 tune = data.getVar("DEFAULTTUNE:virtclass-multilib-%s" % lib)
305 return subprocess.check_output(["stat", "-f", "-c", "%t", path]).decode('utf-8').strip()
317 # Check that the path is on a case-sensitive file system
322 return "The %s (%s) can't be on a case-insensitive file system.\n" % (name, path)
389 …bb.warn('Host distribution "%s" has not been validated with this version of the build system; you …
427 # Patch before 2.7 can't handle all the features in git-style diffs. Some
433 … result = subprocess.check_output(["patch", "--version"], stderr=subprocess.STDOUT).decode('utf-8')
434 version = re.search(r"[0-9.]+", result.splitlines()[0]).group()
440 return "Unable to execute patch --version, exit code %d:\n%s\n" % (e.returncode, e.output)
447 … result = subprocess.check_output(['make', '--version'], stderr=subprocess.STDOUT).decode('utf-8')
449 return "Unable to execute make --version, exit code %d\n%s\n" % (e.returncode, e.output)
458 …rsion 4.2.1 is known to have issues on Centos/OpenSUSE and other non-Ubuntu systems. Please use a …
467 # https://docs.microsoft.com/en-us/windows/wsl/wsl2-install
500 …ee https://discourse.ubuntu.com/t/ubuntu-24-04-lts-noble-numbat-release-notes/39890#unprivileged-u…
505 # This can be fixed on CentOS-7 with devtoolset-6+
506 # https://www.softwarecollections.org/en/scls/rhscl/devtoolset-6/
508 # A less invasive fix is with scripts/install-buildtools (or with user
509 # built buildtools-extended-tarball)
517 …r version of gcc (you could use the project's buildtools-extended-tarball or use scripts/install-b…
522 # Version 1.28 is needed so opkg-build works correctly when reproducible builds are enabled
527 … result = subprocess.check_output(["tar", "--version"], stderr=subprocess.STDOUT).decode('utf-8')
529 return "Unable to execute tar --version, exit code %d\n%s\n" % (e.returncode, e.output)
531 …tall gtar (you could use the project's buildtools-tarball from our last release or use scripts/ins…
534 …on of tar (you could use the project's buildtools-tarball from our last release or use scripts/ins…
537 … result = subprocess.check_output(["tar", "--help"], stderr=subprocess.STDOUT).decode('utf-8')
538 if "--xattrs" not in result:
539 return "Your tar doesn't support --xattrs, please use GNU tar.\n"
541 return "Unable to execute tar --help, exit code %d\n%s\n" % (e.returncode, e.output)
551 … result = subprocess.check_output(["git", "--version"], stderr=subprocess.DEVNULL).decode('utf-8')
553 return "Unable to execute git --version, exit code %d\n%s\n" % (e.returncode, e.output)
567 subprocess.check_output(["perl", "-e", "use %s" % m])
582 bb.build.exec_func(func, d)
589 indexes = glob.glob(d.expand("${SSTATE_MANIFESTS}/index-${BUILD_ARCH}_*"))
652 # In other words, these tests run once in a given build directory and then
656 # minimal installations: glib-2.0-natives requires xml.parsers.expat
694 if "diffstat-native" not in assume_provided:
703 status.addresult("TMPDIR is setgid, please don't build in a setgid directory")
705 status.addresult("TMPDIR is setuid, please don't build in a setuid directory")
712 …n a path included in PSEUDO_IGNORE_PATHS " + str(i) + " please locate the build outside this path.…
724 # Some third-party software apparently relies on chmod etc. being suid root (!!)
732 …et. This interferes with pseudo and may cause other issues that break the build process.\n' % bin_…
746 …f os.path.exists('%s/libc.so.6' % lib32path) and not os.path.exists('/usr/include/gnu/stubs-32.h'):
747 …status.addresult("You have a 32-bit libc, but no 32-bit headers. You must install the 32-bit libc…
769 # Check for case-insensitive file systems (such as Linux in Docker on
770 # macOS with default HFS+ file system)
775 Currently bitbake switches locale to en_US.UTF-8 so check that this locale actually exists.
779 locale.setlocale(locale.LC_ALL, "en_US.UTF-8")
781 raise_sanity_error("Your system needs to support the en_US.UTF-8 locale.", d)
785 # Sanity tests which test the users environment so need to run at each build (or are so cheap
794 …status.addresult('The system requires at least Python 3.8 to run. Please update your Python interp…
805 …status.addresult("PATH contains '.', './' or '' (empty element), which will break the build, pleas…
825 # Check that these variables don't use tilde-expansion as we don't do that
855 if not check_conf_exists("conf/machine-sdk/${SDKMACHINE}.conf", d):
858 …status.addresult('SDKMACHINE is set, but SDK_ARCH has not been changed as a result - SDKMACHINE ma…
860 # If SDK_VENDOR looks like "-my-sdk" then the triples are badly formed so fail early
862 if not (sdkvendor.startswith("-") and sdkvendor.count("-") == 1):
863 …status.addresult("SDK_VENDOR should be of the form '-foosdk' with a single dash; found '%s'\n" % s…
877 # This path is no longer user-readable in modern (very recent) Linux
891 if val.find('..') != -1:
893 if val.find('+') != -1:
895 if val.find('@') != -1:
897 if val.find(' ') != -1:
899 if val.find('%') != -1:
943 mirror_base = urllib.parse.urlparse(mirror[:-1*len('/PATH')]).path
974 # Due to update-alternatives, the shell name may take various