Lines Matching +full:pm +full:- +full:related

1 # waf is a build system which is used by samba related project.
6 DEPENDS += "qemu-native libxslt-native docbook-xsl-stylesheets-native python3"
8 CONFIGUREOPTS = " --prefix=${prefix} \
9 --bindir=${bindir} \
10 --sbindir=${sbindir} \
11 --libexecdir=${libexecdir} \
12 --datadir=${datadir} \
13 --sysconfdir=${sysconfdir} \
14 --sharedstatedir=${sharedstatedir} \
15 --localstatedir=${localstatedir} \
16 --libdir=${libdir} \
17 --includedir=${includedir} \
18 --oldincludedir=${includedir} \
19 --infodir=${infodir} \
20 --mandir=${mandir} \
24 # avoids build breaks when using no-static-libs.inc
28 pm = d.getVar('PARALLEL_MAKE')
29 if pm:
30 # look for '-j' and throw other options (e.g. '-l') away
32 pm = pm.split()
33 while pm:
34 opt = pm.pop(0)
35 if opt == '-j':
36 v = pm.pop(0)
37 elif opt.startswith('-j'):
43 return '-j' + str(v)
49 # Only --cross-answers - try the cross-answers file, and if
53 # Only --cross-execute - get the answer from cross-execute,
54 # an emulator (qemu) is used to run cross-compiled binaries.
59 # Try the cross-answers file first, and if there is no
60 # corresponding answer, use cross-execute to get an answer,
70 # Prepare the cross-answers file
71 WAF_CROSS_ANSWERS_PATH="${THISDIR}/../../files/waf-cross-answers"
72 CROSS_ANSWERS="${B}/cross-answers-${TARGET_ARCH}.txt"
73 if [ -e ${CROSS_ANSWERS} ]; then
74 rm -f ${CROSS_ANSWERS}
78 cat ${WAF_CROSS_ANSWERS_PATH}/cross-answers-${TARGET_ARCH}.txt >> ${CROSS_ANSWERS}
81 if [ "${qemu_binary}" = "qemu-allarch" ]; then
90 -L ${STAGING_DIR_HOST} \
91 -E LD_LIBRARY_PATH=${libdir_qemu}:${base_libdir_qemu}"
99 export PYTHON_CONFIG=${STAGING_EXECPREFIXDIR}/python-target-config/python3-config
101 CONFIG_CMD="./configure ${CONFIGUREOPTS} ${EXTRA_OECONF} --cross-compile"
103 ${CONFIG_CMD} --cross-answers="${CROSS_ANSWERS}"
105 ${CONFIG_CMD} --cross-exec="${CROSS_EXEC}"
107 ${CONFIG_CMD} --cross-answers="${CROSS_ANSWERS}" --cross-exec="${CROSS_EXEC}"
109 echo "ERROR: ${CROSS_METHOD} is not valid for cross-compile!"
116 python3 ./buildtools/bin/waf ${@oe.utils.parallel_make_argument(d, '-j%d', limit=64)}