Lines Matching +full:pre +full:- +full:verified
10 # u-boot-aspeed-sdk commit '2c3b53489c ast2600: Modify SPL SRAM layout'
14 # newer (post v00.03.03) u-boot-aspeed-sdk need this set to false
17 SOCSEC_SIGN_EXTRA_OPTS ?= "--stack_intersects_verification_region=false --rsa_key_order=big"
18 DEPENDS += '${@oe.utils.conditional("SOCSEC_SIGN_ENABLE", "1", " socsec-native", "", d)}'
21 # Signs the SPL binary with a pre-established key
25 if [ "${SOC_FAMILY}" != "aspeed-g6" ] ; then
27 elif [ ! -e "${SOCSEC_SIGN_KEY}" ] ; then
30 rm -f ${SPL_BINARY}.staged
32 if [ -n "${SOCSEC_SIGN_HELPER}" ] ; then
33 signing_helper_args="--signing_helper ${SOCSEC_SIGN_HELPER}"
36 --soc ${SOCSEC_SIGN_SOC} \
37 --algorithm ${SOCSEC_SIGN_ALGO} \
38 --rsa_sign_key ${SOCSEC_SIGN_KEY} \
39 --bl1_image ${DEPLOYDIR}/${SPL_IMAGE} \
42 --output ${SPL_BINARY}.staged
43 cp -f ${SPL_BINARY}.staged ${B}/$CONFIG_B_PATH/${SPL_BINARY}
44 mv -f ${SPL_BINARY}.staged ${DEPLOYDIR}/${SPL_IMAGE}
49 mkdir -p ${DEPLOYDIR}
50 if [ -n "${UBOOT_CONFIG}" ]; then
66 --sec_image ${DEPLOYDIR}/${SPL_IMAGE} \
67 --otp_image ${DEPLOYDIR}/"$(basename ${otptool_config} .json)"-otp-all.image
69 if [ $? -ne 0 ]; then
70 bbfatal "Verified OTP image failed."
76 if [ "${SOCSEC_SIGN_ENABLE}" = "1" -a -n "${SPL_BINARY}" ] ; then