#
b518e9e9 |
| 24-Aug-2021 |
Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com> |
block/backup: move cluster size calculation to block-copy
The main consumer of cluster-size is block-copy. Let's calculate it here instead of passing through backup-top.
We are going to publish cop
block/backup: move cluster size calculation to block-copy
The main consumer of cluster-size is block-copy. Let's calculate it here instead of passing through backup-top.
We are going to publish copy-before-write filter soon, so it will be created through options. But we don't want for now to make explicit option for cluster-size, let's continue to calculate it automatically. So, now is the time to get rid of cluster_size argument for bdrv_cbw_append().
Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com> Reviewed-by: Max Reitz <mreitz@redhat.com> Message-Id: <20210824083856.17408-10-vsementsov@virtuozzo.com> [hreitz: Add qemu/error-report.h include to block/block-copy.c] Signed-off-by: Hanna Reitz <hreitz@redhat.com>
show more ...
|
#
2a6511df |
| 24-Aug-2021 |
Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com> |
block/backup: set copy_range and compress after filter insertion
We are going to publish copy-before-write filter, so it would be initialized through options. Still we don't want to publish compress
block/backup: set copy_range and compress after filter insertion
We are going to publish copy-before-write filter, so it would be initialized through options. Still we don't want to publish compress and copy-range options, as
1. Modern way to enable compression is to use compress filter.
2. For copy-range it's unclean how to make proper interface: - it's has experimental prefix for backup job anyway - the whole BackupPerf structure doesn't make sense for the filter So, let's just add copy-range possibility to the filter later if needed.
Still, we are going to continue support for compression and experimental copy-range in backup job. So, set these options after filter creation.
Note, that we can drop "compress" argument of bdrv_cbw_append() now, as well as "perf". The only reason not doing so is that now, when I prepare this patch the big series around it is already reviewed and I want to avoid extra rebase conflicts to simplify review of the following version.
Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com> Reviewed-by: Hanna Reitz <hreitz@redhat.com> Message-Id: <20210824083856.17408-9-vsementsov@virtuozzo.com> Signed-off-by: Hanna Reitz <hreitz@redhat.com>
show more ...
|
#
49577723 |
| 24-Aug-2021 |
Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com> |
block-copy: move detecting fleecing scheme to block-copy
We want to simplify initialization interface of copy-before-write filter as we are going to make it public. So, let's detect fleecing scheme
block-copy: move detecting fleecing scheme to block-copy
We want to simplify initialization interface of copy-before-write filter as we are going to make it public. So, let's detect fleecing scheme exactly in block-copy code, to not pass this information through extra levels.
Why not just set BDRV_REQ_SERIALISING unconditionally: because we are going to implement new more efficient fleecing scheme which will not rely on backing feature.
Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com> Reviewed-by: Hanna Reitz <hreitz@redhat.com> Message-Id: <20210824083856.17408-7-vsementsov@virtuozzo.com> Signed-off-by: Hanna Reitz <hreitz@redhat.com>
show more ...
|
#
d003e0ae |
| 24-Aug-2021 |
Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com> |
block: rename backup-top to copy-before-write
We are going to convert backup_top to full featured public filter, which can be used in separate of backup job. Start from renaming from "how it used" t
block: rename backup-top to copy-before-write
We are going to convert backup_top to full featured public filter, which can be used in separate of backup job. Start from renaming from "how it used" to "what it does".
While updating comments in 283 iotest, drop and rephrase also things about ".active", as this field is now dropped, and filter doesn't have "inactive" mode.
Note that this change may be considered as incompatible interface change, as backup-top filter format name was visible through query-block and query-named-block-nodes.
Still, consider the following reasoning:
1. backup-top was never documented, so if someone depends on format name (for driver that can't be used other than it is automatically inserted on backup job start), it's a kind of "undocumented feature use". So I think we are free to change it.
2. There is a hope, that there is no such users: it's a lot more native to give a good node-name to backup-top filter if need to operate with it somehow, and don't touch format name.
3. Another "incompatible" change in further commit would be moving copy-before-write filter from using backing child to file child. And this is even more reasonable than renaming: for now all public filters are file-child based.
So, it's a risky change, but risk seems small and good interface worth it.
Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com> Reviewed-by: Max Reitz <mreitz@redhat.com> Message-Id: <20210824083856.17408-6-vsementsov@virtuozzo.com> Signed-off-by: Hanna Reitz <hreitz@redhat.com>
show more ...
|